最专业的脚本、辅助学习平台,易语言培训/C++教程学习基地
查看: 228|回复: 2

求教自动寻路的一个小问题

[复制链接]
  • TA的每日心情
    开心
    2021-4-20 10:09
  • 发表于 2021-4-29 11:58:06 | 显示全部楼层 |阅读模式
    .版本 2
    .支持库 spec


    .判断循环首 (真)
        坐标1 = 大漠.FetchWord (882, 29, 942, 48, “f6debe-504D49”, “寻路中”)
        辅助延时 (3000)
        坐标2 = 大漠.FetchWord (882, 29, 942, 48, “f6debe-504D49”, “寻路中”)
        .如果真 (坐标1 = 坐标2)
            调试输出 (“到达目的地”)
            跳出循环 ()
        .如果真结束
        调试输出 (“寻路中”)
    .判断循环尾 ()
      现在问题是在寻路的时候 偶尔有时候会被怪物包围走不了,怎么返回重新进图跑图 或者清怪 在继续跑 求教育

    该用户从未签到

    发表于 2021-5-13 10:59:47 | 显示全部楼层
    这个没法说啊,你这个只是判断颜色对不对
    回复

    使用道具 举报

  • TA的每日心情
    可爱
    5 小时前
  • 发表于 2021-5-13 23:59:11 | 显示全部楼层
    楼主发贴辛苦了
    回复

    使用道具 举报

    懒得打字嘛,点击右侧快捷回复 【右侧内容,后台自定义】
    您需要登录后才可以回帖 登录 | 立即注册

    本版积分规则

    关闭

    站长推荐上一条 /7 下一条

     
     
    点击这里给我发消息
    工作时间:
    9:00-22:00
    天野学院1群:427873953
    快速回复 返回顶部 返回列表