最专业的脚本、辅助学习平台,易语言培训/C++教程学习基地
查看: 127|回复: 4

小小源码

[复制链接]
  • TA的每日心情
    开心
    2019-5-26 01:14
  • 发表于 2019-5-26 01:36:28 | 显示全部楼层 |阅读模式
    .版本 2
    .支持库 edroptarget

    .程序集 窗口程序集_启动窗口

    .子程序 __启动窗口_创建完毕

    ' 运行 (“regsvr32 dm.dll”, 假, )


    ' 大漠.创建 ()

    ' 大漠.SetPath (取运行目录 ())  ' 设置大漠全局路径
    ' 大漠.SetDict (0, “ziku0.txt”)  ' 设置大漠的字库文件

    拖放对象1.注册拖放控件 (编辑框游戏路径.取窗口句柄 ())


    .子程序 __启动窗口_将被销毁

    大漠.释放 ()


    .子程序 _按钮减号_被单击

    通用对话框1.类型 = 0
    .如果真 (通用对话框1.打开 ())
        编辑框游戏路径.内容 = 通用对话框1.文件名

    .如果真结束


    .子程序 _拖放对象1_得到文件
    .参数 接收到的文件路径, 文本型

    编辑框游戏路径.内容 = 接收到的文件路径


    .子程序 _按钮保存配置_被单击


    .如果 (编辑框账号.内容 ≠ “”)
        写配置项 (取运行目录 () + “\配置.ini”, “配置”, “账号”, 编辑框账号.内容)
        .如果 (编辑框密码.内容 ≠ “”)
            写配置项 (取运行目录 () + “\配置.ini”, “配置”, “密码”, 编辑框密码.内容)
            .如果 (编辑框游戏路径.内容 ≠ “”)
                写配置项 (取运行目录 () + “\配置.ini”, “配置”, “路径”, 编辑框游戏路径.内容)
            .否则

            .如果结束

        .否则

        .如果结束

    .否则

    .如果结束




    .子程序 _按钮读取配置_被单击

    编辑框账号.内容 = 读配置项 (取运行目录 () + “\配置.ini”, “配置”, “账号”, )
    编辑框密码.内容 = 读配置项 (取运行目录 () + “\配置.ini”, “配置”, “密码”, )
    编辑框游戏路径.内容 = 读配置项 (取运行目录 () + “\配置.ini”, “配置”, “路径”, )

    .子程序 _按钮打开_被单击

    运行 (编辑框游戏路径.内容, 假, )


  • TA的每日心情
    偷笑
    2019-6-9 19:01
  • 发表于 2019-5-27 17:46:42 | 显示全部楼层
    小小源码
    回复

    使用道具 举报

  • TA的每日心情
    慵懒
    2019-6-9 12:15
  • 发表于 2019-6-7 10:20:29 | 显示全部楼层

    感谢楼主的无私分享!要想天野学院好 就靠你我他
    回复

    使用道具 举报

  • TA的每日心情
    奋斗
    2019-6-15 22:29
  • 发表于 2019-6-11 20:27:53 | 显示全部楼层

    看不懂啊!!!
    回复

    使用道具 举报

  • TA的每日心情
    开心
    2019-6-16 08:25
  • 发表于 2019-6-13 23:02:44 | 显示全部楼层
    真的很感谢!!
    回复

    使用道具 举报

    懒得打字嘛,点击右侧快捷回复 【右侧内容,后台自定义】
    您需要登录后才可以回帖 登录 | 立即注册

    本版积分规则

    
    关闭

    站长推荐上一条 /7 下一条

     
     
    点击这里给我发消息
    工作时间:
    9:00-22:00
    天野学院1群:427873953
    快速回复 返回顶部 返回列表